hdoj 1892 See you~(二維樹狀數組)

hdoj 1892 See you~
鏈接

Problem Description

Now I am leaving hust acm. In the past two and half years, I learned so many knowledge about Algorithm and Programming, and I met so many good friends. I want to say sorry to Mr, Yin, I must leave now >.<. I am very sorry, we could not advanced to the World Finals last year.
When coming into our training room, a lot of books are in my eyes. And every time the books are moving from one place to another one. Now give you the position of the books at the early of the day. And the moving information of the books the day, your work is to tell me how many books are stayed in some rectangles.
To make the problem easier, we divide the room into different grids and a book can only stayed in one grid. The length and the width of the room are less than 1000. I can move one book from one position to another position, take away one book from a position or bring in one book and put it on one position.

Input

In the first line of the input file there is an Integer T(1<=T<=10), which means the number of test cases in the input file. Then N test cases are followed.
For each test case, in the first line there is an Integer Q(1<Q<=100,000), means the queries of the case. Then followed by Q queries.
There are 4 kind of queries, sum, add, delete and move.
For example:
S x1 y1 x2 y2 means you should tell me the total books of the rectangle used (x1,y1)-(x2,y2) as the diagonal, including the two points.
A x1 y1 n1 means I put n1 books on the position (x1,y1)
D x1 y1 n1 means I move away n1 books on the position (x1,y1), if less than n1 books at that position, move away all of them.
M x1 y1 x2 y2 n1 means you move n1 books from (x1,y1) to (x2,y2), if less than n1 books at that position, move away all of them.
Make sure that at first, there is one book on every grid and 0<=x1,y1,x2,y2<=1000,1<=n1<=100.

Output

At the beginning of each case, output “Case X:” where X is the index of the test case, then followed by the “S” queries.
For each “S” query, just print out the total number of books in that area.

Sample Input

2
3
S 1 1 1 1
A 1 1 2
S 1 1 1 1
3
S 1 1 1 1
A 1 1 2
S 1 1 1 2

Sample Output

Case 1:
1
3
Case 2:
1
4

Solution

二維平面單點修改 + 區間查詢
邊查邊修改 , 用二維樹狀數組做二維前綴和

代碼

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

typedef long long ll;

const int SZ = 1000 + 10;

int n,tree[SZ][SZ],cnt,num[SZ][SZ];

inline int lowbit(int x)
{
	return x & (-x);
}

inline void update_tree(int x,int y,int c)
{
	while(x <= 1005)
	{
		int yy = y;
		while(yy <= 1005)
		{
			tree[x][yy] += c;
			yy += lowbit(yy);
		}
		x += lowbit(x);
	}
}

inline int query_tree(int x,int y)
{
	int sum = 0;
	while(x > 0)
	{
		int yy = y;
		while(yy > 0)
		{
			sum += tree[x][yy];
			yy -= lowbit(yy);
		}
		x -= lowbit(x);
	}
	return sum;
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T -- )
	{
		memset(tree,0,sizeof(tree));
		memset(num,0,sizeof(num));
		char ch;
		int x1,y1,x2,y2,c;
		scanf("%d",&n);
		printf("Case %d:\n", ++ cnt);
		for(int i = 1;i <= 1005; i ++ )
			for(int j = 1;j <= 1005 ;j ++ )
			{
				update_tree(i,j,1);
				num[i][j] = 1;
			}
			getchar();
		for(int i = 1; i <= n;i ++ )
		{
			scanf("%c",&ch);
			if(ch == 'S')
			{
				scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
				x1++,x2++,y1++,y2++;
				if(x1 > x2) swap(x1,x2);
				if(y1 > y2) swap(y1,y2);
				int ans = query_tree(x2,y2) - query_tree(x2,y1 - 1) - query_tree(x1 - 1,y2) + query_tree(x1 - 1,y1 - 1);
				printf("%d\n",ans);
			}
			else if(ch == 'A')
			{
				scanf("%d%d%d",&x1,&y1,&c);
				x1++;
				y1++;
				update_tree(x1,y1,c);
				num[x1][y1] += c;
			}
			else if(ch == 'M')
			{
				scanf("%d%d%d%d%d",&x1,&y1,&x2,&y2,&c);
				x1 ++ ,y1 ++ ,x2 ++ ,y2 ++ ;
				if(c > num[x1][y1]) c = num[x1][y1];
				update_tree(x1,y1,-c);
				update_tree(x2,y2,c);
				num[x1][y1] -= c;
				num[x2][y2] += c;
			}
			else if(ch == 'D')
			{
				scanf("%d%d%d",&x1,&y1,&c);
				x1 ++ ,y1 ++ ;
				if(c > num[x1][y1]) c = num[x1][y1];
				update_tree(x1,y1,-c);
				num[x1][y1] -= c;
			}
			getchar();
		}
	}
	return 0;
}

2020.4.2

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章