PAT 甲級1012 The Best Rank 排序

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A

程序正確但運行超時。。。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.Arrays;
import java.util.Comparator;

class Student{
	int id;
	int[] grades=new int[4];//分別存放A C M E
	public Student(int id,int c,int m,int e) {
		this.id=id;
		this.grades[1]=c;
		this.grades[2]=m;
		this.grades[3]=e;
		this.grades[0]=(c+m+e)/3;
	}
}

public class Main {

	static class Cmp implements Comparator<Student>{
		int cur;
		@Override
		public int compare(Student o1, Student o2) {
			
			return o2.grades[cur]-o1.grades[cur];//降序排列
		}
		
	}
    public static void main(String[] args) throws IOException {
    	BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));

//    	Scanner sc=new Scanner(System.in);

    	String[] line=reader.readLine().split(" ");
    	int N=Integer.valueOf(line[0]),M=Integer.valueOf(line[1]);
    	Student[] stu=new Student[N];
    	int[][] Ranks=new int[1000000][4];//存放排名
    	char[] subjects= {'A','C','M','E'};
    			
    	for(int i=0;i<N;i++) {
    		line=reader.readLine().split(" ");
    		Student s=new Student(Integer.valueOf(line[0]), Integer.valueOf(line[1]),
    				Integer.valueOf(line[2]),Integer.valueOf(line[3]));
    		stu[i]=s;
    	}
    	int cur;//cur依次遍歷A C M E
		Cmp cmp=new Cmp();
    	for(cur=0;cur<4;cur++) {
    		cmp.cur=cur;
        	Arrays.sort(stu,0,N,cmp);
        	Ranks[stu[0].id][cur]=1;
        	for(int i=1;i<N;i++) {
        		if(stu[i].grades[cur]==stu[i-1].grades[cur]) {//與前一位並列
        			Ranks[stu[i].id][cur]=Ranks[stu[i-1].id][cur];
        		}else {
        			Ranks[stu[i].id][cur]=i+1;
        		}
        	}
    	}
    	for(int i=0;i<M;i++) {
    		int id=Integer.valueOf(reader.readLine());
    		if(Ranks[id][0]==0) {//不存在
    			System.out.println("N/A");
    		}else {
    			//找出最小排名
    			int k=0,r=Ranks[id][0];
    			for(int j=1;j<4;j++) {
    				if(Ranks[id][j]<r) {
    					k=j;
    					r=Ranks[id][j];
    				}
    			}
    			System.out.println(r+" "+subjects[k]);
    		}
    	}
    }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章