1062 Talent and Virtue (25point(s)) - C語言 PAT 甲級

1062 Talent and Virtue (25point(s))

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people’s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a “sage(聖人)”; being less excellent but with one’s virtue outweighs talent can be called a “nobleman(君子)”; being good in neither is a “fool man(愚人)”; yet a fool man is better than a “small man(小人)” who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang’s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (≤105), the total number of people to be ranked; L (≥60), the lower bound of the qualified grades – that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification – that is, those with both grades not below this line are considered as the “sages”, and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the “noblemen”, and are also ranked in non-increasing order according to their total grades, but they are listed after the “sages”. Those with both grades below H, but with virtue not lower than talent are considered as the “fool men”. They are ranked in the same way but after the “noblemen”. The rest of people whose grades both pass the L line are ranked after the “fool men”.

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (≤N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID’s.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

題目大意:

1015 德才論

設計思路:

1015 德才論(C語言)

  1. 在輸入過程中將不錄取數據丟棄,並返回錄取人數
  2. 利用 qsort 函數進行快速排序,防止超時
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

typedef struct {
        int id;
        int d;
        int c;
        int sum;
        int r;
}Student;

int inputstudent(int n, int low, int high, Student s[]); /*input 並返回合格人數*/
int compstudent(const void *a, const void *b); /*爲 qsort 提供比較函數*/
int cmpstudent(int n, Student s[]); /*此冒泡排序超時,棄用*/
int outputstudent(int m, Student s[]); /*output*/

int main()
{
        int n, low, high, m;
        Student students[100000];

        scanf("%d %d %d",&n, &low, &high);
        m = inputstudent(n, low, high, students);
        qsort(students, m, sizeof(students[0]), compstudent);
        outputstudent(m, students);

        return 0;
}

int inputstudent(int n, int low, int high, Student s[])
{
        int i,m=0;
        Student temp;
        for (i = 0; i < n-m; i++) {
                scanf("%d %d %d", &s[i].id, &s[i].d, &s[i].c);
                s[i].sum = s[i].d + s[i].c;
                if (s[i].d < low || s[i].c < low) {
                        m++;
                        i--;
                } else if (s[i].d >= high && s[i].c >= high) {
                        s[i].r = 4;
                } else if (s[i].d >= high) {
                        s[i].r = 3;
                } else if (s[i].d >= s[i].c) {
                        s[i].r = 2;
                } else {
                        s[i].r =1;
                }
        }
        return n-m;
}

int compstudent(const void *s1, const void *s2)
{
        Student *a = (Student *)s1;
        Student *b = (Student *)s2;
        if (a->r != b->r)          return a->r - b->r;
        else if (a->sum != b->sum) return a->sum - b->sum;
        else if (a->d != b->d)     return a->d - b->d;
        else if (a->id != b->id)   return b->id - a->id;
        else                      return 0;
}

int outputstudent(int m, Student s[])
{
        int i;
        printf("%d\n", m);
        for (i = m-1; i >= 0; i--) {
                printf("%d %d %d\n", s[i].id, s[i].d, s[i].c);
        }
        return 0;
}

int cmpstudent(int n, Student s[])
{
        int i, j;
        Student temp;
        for (i = 0; i < n; i++) {
                for (j = 0; j < n-i-1; j++) {
                        if (s[j].r < s[j+1].r) {
                                temp = s[j];
                                s[j] = s[j+1];
                                s[j+1] = temp;
                        } else if (s[j].r == s[j+1].r && s[j].sum < s[j+1].sum) {
                                temp = s[j];
                                s[j] = s[j+1];
                                s[j+1] = temp;
                        } else if (s[j].r == s[j+1].r && s[j].sum == s[j+1].sum && s[j].d < s[j+1].d) {
                                temp = s[j];
                                s[j] = s[j+1];
                                s[j+1] = temp;
                        } else if (s[j].r == s[j+1].r && s[j].sum == s[j+1].sum &&(s[j].d == s[j+1].d && s[j].id > s[j+1].id)) {
                                temp = s[j];
                                s[j] = s[j+1];
                                s[j+1] = temp;
                        }

                }
        }
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章