1115 Counting Nodes in a BST (30point(s)) - C語言 PAT 甲級

1115 Counting Nodes in a BST (30point(s))

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node’s key.
  • The right subtree of a node contains only nodes with keys greater than the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−1000,1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

題目大意:

輸入 N 個節點,插入一顆二叉搜索樹,

輸出最後兩層節點的個數 n1、n2,以及它們的和 n1 + n2 = n

設計思路:
  • 邊讀取數據,邊建立一顆二叉搜索樹
  • 建立完成後,再遍歷一次,記錄每層的個數,和最深層 max
  • 輸出最後兩層的個數
編譯器:C (gcc)
include <stdio.h>
#include <stdlib.h>

struct node {
        int d;
        struct node *left, *right;
};

struct node *build(struct node *root, int d)
{
        if (root == NULL) {
                root = (struct node *)malloc(sizeof(struct node));
                root->d = d;
                root->left = NULL;
                root->right = NULL;
        } else if (d <= root->d) {
                root->left = build(root->left, d);
        } else {
                root->right = build(root->right, d);
        }
        return root;
}

int level[1010] = {0}, maxdepth = 0;

void dfs(struct node *root, int depth)
{
        if (root == NULL) {
                maxdepth = maxdepth > depth ? maxdepth :depth;
                return ;
        }
        level[depth]++;
        dfs(root->left, depth + 1);
        dfs(root->right, depth + 1);
}

int main(void)
{
        int n, t;
        struct node *root = NULL;

        scanf("%d", &n);
        while (n--) {
                scanf("%d", &t);
                root = build(root, t);
        }
        dfs(root, 0);
        printf("%d + %d = %d", level[maxdepth - 1], level[maxdepth - 2], level[maxdepth - 1] + level[maxdepth - 2]);
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章