1108 Finding Average (20point(s)) - C語言 PAT 甲級

1108 Finding Average (20point(s))

The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:

For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input:

7
5 -3.2 aaa 9999 2.3.4 7.123 2.35

Sample Output:

ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38

Sample Input:

2
aaa -9999

Sample Output:

ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined

題目大意:

1054 求平均值 (20point(s))

設計思路:

1054 求平均值(C語言)

  1. 用 scanf("%8s", str) 處理輸入,因爲”合法“輸入最大字節數爲 8 字節,所以一次讀取 8 個字節或遇到空字符停止讀取
  2. double strtod(const char *str, char **endptr) 函數轉換字符串爲浮點數
  3. char *strchr(const char *str, int c) 函數找小數點的位置
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

int main()
{
        int n, count = 0;
        double f, sum = 0;
        char s[9], *send, *sdot, c;

        scanf("%d", &n);
        while (n--) {
                scanf("%8s", s);
                c = ungetc(getchar(), stdin);
                f = strtod(s, &send);
                sdot = strchr(s, '.');

                if(!isspace(c)
                || *send
                || (f> 1000 || f < -1000)
                || (sdot && sdot - s < strlen(s) - 3)) {
                        printf("ERROR: %s", s);
                        while (!isspace(c = getchar()))
                                putchar(c);
                        printf(" is not a legal number\n");
                } else {
                        count++;
                        sum += f;
                }
        }

        if (count == 0)
                printf("The average of 0 numbers is Undefined\n");
        else if (count == 1)
                printf("The average of 1 number is %.2lf", sum);
        else
                printf("The average of %d numbers is %.2lf", count, sum/count);

        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章