1065 A+B and C (64bit) (20point(s)) - C語言 PAT 甲級

1065 A+B and C (64bit) (20point(s))

Given three integers A, B and C in [−263,263], you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

Sample Output:

Case #1: false
Case #2: true
Case #3: false

題目大意:

輸入三個數,A、B、C,問是否 A + B > C

設計思路:

乙級有一題類似,可以用 double 類型混過去,但此題數值過大,double 精度不夠,用 long long 存值,並先判斷正值溢出和負值溢出即可

編譯器:C (gcc)
#include <stdio.h>

int main()
{
        int t, i;
        long long a, b, c, sum;

        scanf("%d", &t);
        for (i = 1; i <= t; i++) {
                scanf("%lld%lld%lld", &a, &b, &c);
                sum = a + b;
                if (a > 0 && b > 0 && sum < 0)
                        printf("Case #%d: true\n", i);
                else if (a < 0 && b < 0 && sum >= 0)
                        printf("Case #%d: false\n", i);
                else if (sum > c)
                        printf("Case #%d: true\n", i);
                else
                        printf("Case #%d: false\n", i);
        }

        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章