1095 Cars on Campus (30point(s)) - C語言 PAT 甲級

1095 Cars on Campus (30point(s))

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤104), the number of records, and K (≤8×104) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

題目大意:

輸入 N 個車牌號,時間,進出記錄,查詢 K 個時間點,輸出校園內車輛的數目,最後並輸出在校園內停留時間最長的車牌號和停留時間,若有多輛,車牌號按字典序從小到大輸出

一輛車出入的配對要求:

  • 多次連續進入,取最後一個值,
  • 多次連續出來,取第一個值
設計思路:

按照車牌號字典序從小到大,時間從小到大對所有車進行排序

  • 遍歷且僅記錄滿足配對要求的每對記錄
  • 遍歷過程中記錄每輛車停留的時間
    • 同一輛車會有多次滿足配對要求的記錄,所以對於停留時間要判斷累加
    • 並記錄最大值和車牌號
  • 利用滿足配對要求的記錄,按秒記錄每個時間點在校園內的車輛數目,查詢時,直接返回對應時間的數目即可
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node {
        char id[10];
        int time;
        int state;
};

int cmp1(const void *a, const void *b)
{
        struct node *x = (struct node *)a, *y = (struct node *)b;
        if (strcmp(x->id, y->id) != 0)
                return strcmp(x->id, y->id);
        return x->time - y->time;
}

int cmp2(const void *a, const void *b)
{
        return (*((struct node **)a))->time - (*((struct node **)b))->time;
}

int main(void)
{
        int n, k;
        int i, j, hh, mm, ss, tempint;
        struct node record[10000], *recordtime[10000];
        char tempstr[5], maxid[10000][10];
        int sum[24 * 3600], cnt, maxtime, maxcnt;

        scanf("%d%d\n", &n, &k);
        for (i = 0; i < n; i++) {
                scanf("%s %d:%d:%d %s\n", record[i].id, &hh, &mm, &ss, tempstr);
                tempint = hh * 3600 + mm * 60 + ss;
                record[i].time = tempint;
                record[i].state = tempstr[0] == 'i' ? 1 : -1;
        }
        qsort(record, n, sizeof(record[0]), cmp1);
        for (i = 1, j = 0; i < n; i++) {
                if (strcmp(record[i - 1].id, record[i].id) == 0 && record[i - 1].state == 1 && record[i].state == -1) {
                        record[j] = record[i - 1];
                        recordtime[j] = &record[j];
                        j++;
                        record[j] = record[i];
                        recordtime[j] = &record[j];
                        j++;

                        if (j == 2) {
                                tempint = record[j - 1].time - record[j - 2].time;
                                maxtime = tempint;
                                strcpy(maxid[0], record[j - 1].id);
                                maxcnt = 1;
                        } else if (j > 2) {
                                if (strcmp(record[j - 1].id, record[j - 3].id) == 0) {
                                        tempint += record[j - 1].time - record[j - 2].time;
                                } else {
                                        tempint = record[j - 1].time - record[j - 2].time;
                                }
                                if (maxtime < tempint) {
                                        maxtime = tempint;
                                        strcpy(maxid[0], record[j - 1].id);
                                        maxcnt = 1;
                                } else if (maxtime == tempint) {
                                        strcpy(maxid[maxcnt], record[j - 1].id);
                                        maxcnt++;
                                }
                        }
                }
        }
        n = j;
        qsort(recordtime, n, sizeof(recordtime[0]), cmp2);
        for (i = 0, j = 0, cnt = 0; i < 24 * 3600; i++) {
                while (j < n && recordtime[j]->time <= i) {
                        if (recordtime[j]->state == 1)
                                cnt++;
                        else
                                cnt--;
                        j++;
                }
                sum[i] = cnt;
        }

        for (i = 0; i < k; i++) {
                scanf("%d:%d:%d", &hh, &mm, &ss);
                tempint = hh * 3600 + mm * 60 + ss;
                printf("%d\n", sum[tempint]);
        }
        for (i = 0; i < maxcnt; i++)
                printf("%s ", maxid[i]);
        printf("%02d:%02d:%02d", maxtime / 3600, (maxtime % 3600) / 60, maxtime % 60);

        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章