1096 Consecutive Factors (20point(s)) - C语言 PAT 甲级

1096 Consecutive Factors (20point(s))

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3×5×6×7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format factor[1]factor[2]…*factor[k], where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
567

题目大意:

输入整数 N,求 N 的最小的连续因子序列

设计思路:

直接暴力循环,枚举以 2 ~ 根号 N 开头的每个序列,最后序列长度为 0,说明是质数

编译器:C (gcc)
#include <stdio.h>
#include <math.h>

int main(void)
{
        int n, m;
        int start = 0, cnt = 0;
        int i, j, k;

        scanf("%d", &n);
        m = (int)sqrt(n);
        for (i = 2; i <= m; i++) {
                k = 0;
                for (j = i; n % j == 0; j *= (i + k))
                        k++;
                if (k > cnt) {
                        cnt = k;
                        start = i;
                }
        }
        if (cnt == 0) {
                printf("1\n%d", n);
        } else {
                printf("%d\n%d", cnt, start);
                for (i = 1; i < cnt; i++)
                        printf("*%d", start + i);
        }
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章