1076 Forwards on Weibo (30point(s)) - C語言 PAT 甲級

1076 Forwards on Weibo (30point(s))

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

題目大意:

輸入有 N 個用戶,L 最大轉發層數,並按照 1 ~ N 的序號給出每個用戶關注的總數和關注 ID

最後一行詢問,某 ID 用戶發出一條微博後最多有多少人轉發

設計思路:

使用隊列實現廣度優先遍歷

  • 每人僅轉發一次,即不可重複入隊
  • 廣度遍歷時,判斷最大層數不超過 L 層
編譯器:C (gcc)
#include <stdio.h>

int v[1010][1010];
int n, l;
int bfs(int x)
{
        int sum = 0, level[1010] = {0}, visit[1010] = {0};
        int q[1010], front, rear;
        int i;

        q[0] = x;
        front = 0;
        rear = 1;
        visit[x] = 1;
        while (front != rear) {
                x = q[front];
                front++;
                for (i = 1; i <= n; i++) {
                        if (v[x][i] && !visit[i] && level[x] < l) {
                                sum++;
                                visit[i] = 1;
                                level[i] = level[x] + 1;
                                q[rear] = i;
                                rear++;
                        }
                }
        }
        return sum;
}
int main(void)
{
        int i, j, k;

        scanf("%d%d", &n, &l);
        for (i = 1; i <= n; i++) {
               scanf("%d", &j);
               while (j--) {
                       scanf("%d", &k);
                       v[k][i] = 1;
               }
        }
        scanf("%d", &k);
        while (k--) {
                scanf("%d", &j);
                printf("%d\n", bfs(j));
        }
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章