1086 Tree Traversals Again (25point(s)) - C語言 PAT 甲級

1086 Tree Traversals Again (25point(s))

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
figure

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

題目大意:

輸入用棧遍歷一顆樹,輸出樹的後序遍歷

設計思路:
  • Push 的順序即爲先序遍歷,Pop 的順序即爲中序遍歷
  • 根據先序和中序得到後序遍歷
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

int pre[40], in[40], precnt = 0, incnt = 0;

void postorder(int iroot, int left, int right)
{
        if (left > right)
                return ;
        int i = left;
        while (in[i] != pre[iroot])
                i++;
        postorder(iroot + 1, left, i - 1);
        postorder(iroot + 1 + i - left, i + 1, right);
        printf("%d%s", pre[iroot], iroot == 0 ? "" : " ");
}

int main(void)
{
        int n;
        int s[40], top = -1;
        char str[10];
        int i, a;

        scanf("%d\n", &n);
        for (i = 0; i < 2 * n; i++) {
                gets(str);
                if (str[1] == 'u') {
                        a = atoi(str + 5);
                        pre[precnt++] = a;
                        s[++top] = a;
                } else {
                        in[incnt++] = s[top--];
                }
        }
        postorder(0, 0, n - 1);

        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章