1083 List Grades (25point(s)) - C語言 PAT 甲級

1083 List Grades (25point(s))

Given a list of N student records with name, ID and grade. You are supposed to sort the records with respect to the grade in non-increasing order, and output those student records of which the grades are in a given interval.

Input Specification:

Each input file contains one test case. Each case is given in the following format:

N
name[1] ID[1] grade[1]
name[2] ID[2] grade[2]
… …
name[N] ID[N] grade[N]
grade1 grade2

where name[i] and ID[i] are strings of no more than 10 characters with no space, grade[i] is an integer in [0, 100], grade1 and grade2 are the boundaries of the grade’s interval. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case you should output the student records of which the grades are in the given interval [grade1, grade2] and are in non-increasing order. Each student record occupies a line with the student’s name and ID, separated by one space. If there is no student’s grade in that interval, output NONE instead.

Sample Input:

4
Tom CS000001 59
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95
60 100

Sample Output:

Mike CS991301
Mary EE990830
Joe Math990112

Sample Input:

2
Jean AA980920 60
Ann CS01 80
90 95

Sample Output:

NONE

題目大意:

輸入 N 個學生的信息,按照分數從大到小排序,輸出最後一行所給區間的學生信息

設計思路:

直接排序,輸出,學生成績各不相同

編譯器:C (gcc)
#include <stdio.h>

struct node {
        char name[11], id[11];
        int grade;
};

int cmp(const void *a, const void *b)
{
        return ((struct node *)b)->grade - ((struct node *)a)->grade;
}

int main(void)
{
        int n, g1, g2;
        struct node stu[100000];
        int cnt, i;

        scanf("%d", &n);
        for (i = 0; i < n; i++)
                scanf("%s%s%d", stu[i].name, stu[i].id, &stu[i].grade);
        scanf("%d%d", &g1, &g2);
        qsort(stu, n, sizeof(stu[0]), cmp);
        int flag = 0;
        for (i = 0; i < n; i++) {
                if (stu[i].grade >= g1 && stu[i].grade <= g2) {
                        printf("%s %s\n", stu[i].name, stu[i].id);
                        flag = 1;
                }
        }
        if (flag == 0)
                printf("NONE");
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章