1097 Deduplication on a Linked List (25point(s)) - C语言 PAT 甲级

1097 Deduplication on a Linked List (25point(s))

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题目大意:

输入一个链表,去重绝对值相等的节点,先输出去重后的节点,后输出被删除的节点

设计思路:
  • 第一遍遍历,利用 num[] 数组输出绝对值不重复的节点,并把输出的节点标记
  • 第二遍遍历,输出未被标记的节点
编译器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

struct node {
        int d, next;
        int flag;
};

int main(void)
{
        int root, n, root2 = -1;
        struct node list[100000] = {0};
        int num[10010] = {0};
        int i, t, f;

        scanf("%d%d", &root, &n);
        for (i = 0; i < n; i++) {
                scanf("%d", &t);
                scanf("%d%d", &list[t].d, &list[t].next);
        }
        f = 0;
        i = root;
        if (i != -1) {
                f = 1;
                printf("%05d %d ", i, list[i].d);
                list[i].flag = 1;
                num[abs(list[i].d)] = 1;
                i = list[i].next;
        }
        while (i != -1) {
                if (num[abs(list[i].d)] == 0) {
                        printf("%05d\n%05d %d ", i, i, list[i].d);
                        list[i].flag = 1;
                        num[abs(list[i].d)] = 1;
                } else {
                        if (root2 < 0)
                                root2 = i;
                }
                i = list[i].next;
        }
        if (f == 1)
                printf("-1\n");
        f = 0;
        i = root2;
        if (i != -1) {
                f = 1;
                printf("%05d %d ", i, list[i].d);
                i = list[i].next;
        }
        while (i != -1) {
                if (list[i].flag == 0)
                        printf("%05d\n%05d %d ", i, i, list[i].d);
                i = list[i].next;
        }
        if (f == 1)
                printf("-1\n");
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章