1079 Total Sales of Supply Chain (25point(s)) - C语言 PAT 甲级

1079 Total Sales of Supply Chain (25point(s))

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:

Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K​i​​ ID[1] ID[2] … ID[Ki]

where in the i-th line, K​i​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after Kj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 1010.

Sample Input:

10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3

Sample Output:

42.4

题目大意:

输入一颗树 N 个节点,根节点为 0 且货物价格为 P,每向下走一层,货物价格会增加 r%,

接下来输入 N 个节点的 K 个孩子,若 K 为 0 则表示叶节点,并给出每个叶节点给出货物量,

求所有叶节点的售价之和

设计思路:

价格仅和叶节点层数有关,所以利用并查集的思想,记录每个节点的父节点,以递推出叶节点的层数

  • level[v] = get_level(father[v]) + 1,要用数组 level 记录层级信息,不记录的话每次都查询到根节点,会超时
  • 根节点 level[0] = 0
编译器:C (gcc)
#include <stdio.h>
#include <math.h>

double sum = 0.0, p, r;
int father[100010], level[100010], retailer[100010];

int get_level(int v)
{
        if (v == 0)
                return 0;
        if (level[v] > 0)
                return level[v];
        level[v] = get_level(father[v]) + 1;
        return level[v];
}

int main(void)
{
        int n, k, c;
        int i, j;

        scanf("%d%lf%lf", &n, &p, &r);
        r = r / 100.0;
        for (i = 0; i < n; i++) {
                scanf("%d", &k);
                if (k == 0) {
                        scanf("%d", &retailer[i]);
                } else {
                        for (j = 0; j < k; j++) {
                                scanf("%d", &c);
                                father[c] = i;
                        }
                }
        }
        for (i = 0; i < n; i++) {
                if (retailer[i] > 0) {
                        sum += retailer[i] * pow(1 + r, get_level(i));
                }
        }
        printf("%.1lf", sum * p);
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章