1078 Hashing (25point(s)) - C语言 PAT 甲级

1078 Hashing (25point(s))

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤104) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题目大意:

输入散列表长度 Msize,若不是素数,需要重新赋值为第一个比它大的素数,和 N 个数据依次插入散列表,散列函数为 H(key)=key%TSize,解决冲突用正向的平方探测法

输出每个数据插入的位置,无法插入用 -

设计思路:
  1. 输入的 Msize 若不是素数,需要重新赋值为第一个比它大的素数
  2. 平方探测法 index = (key + i * i) % size
编译器:C (gcc)
#include <stdio.h>

int isprime(int n)
{
        if (n == 1)
                return 0;
        int i;
        for (i = 2; i * i <= n; i++)
                if (n % i == 0)
                        return 0;
        return 1;
}

int hash[10007], size;

void insert(int key)
{
        int index, i;
        for (i = 0; i < size; i++) {
                index = (key + i * i) % size;
                if (hash[index] == 0) {
                        hash[index] = 1;
                        printf("%d", index);
                        return ;
                }
        }
        putchar('-');
}

int main(void)
{
        int n;
        int i, key;

        scanf("%d%d", &size, &n);
        while (!isprime(size))
                size++;
        for (i = 0; i < n; i++) {
                scanf("%d", &key);
                if (i != 0)
                        printf(" ");
                insert(key);
        }
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章