1073 Scientific Notation (20point(s)) - C語言 PAT 甲級

1073 Scientific Notation (20point(s))

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [±][1-9].[0-9]+E[±][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent’s signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent’s absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input:

+1.23400E-03

Sample Output:

0.00123400

Sample Input:

-1.2E+10

Sample Output:

-12000000000

題目大意:

1024 科學計數法 (20point(s))

設計思路:

1024 科學計數法(C語言)

  1. 數字的正負號決定輸出普通數字的正負
  2. 指數的正負號決定小數點的移動
編譯器:C (gcc)
#include <stdio.h>
#include <string.h>

int movepoint(char n[], int index);/*當指數爲正,向右移動小數點*/
/*此函數用 '\0' 判斷補 0 和輸出小數點,數組至少需要 10002 個空間,定義 n[10003]*/

int rightprint(char n[], int index);
/*此函數利用指針直接循環輸出,數組空間達題目要求即可,定義 n[10000](參考源碼來自https://oliverlew.github.io/PAT/Basic/1024.html)*/

int main()
{
    int index;
    char n[10003] = {'\0'};
    scanf("%[^E]E%d", n, &index);
    if(n[0] == '-') printf("-");
    if(index >= 0){
        movepoint(n, index);
        printf("%s\n", n+1);
    }
    else{
        printf("0.");
        for(index++; index; index++){
            printf("0");
        }
        printf("%c%s\n", n[1], n+3);
    }
    return 0;
}

int movepoint(char n[], int index)
{
    char *p = n+2;
    for(; index; index--){
        if(*(p+1) != '\0') *p = *(p+1);
        else               *p = '0';
        p++;
        *p = '.';
    }
    if(*(p+1) == '\0') *p = '\0';
    return 0;
}

int rightprint(char n[], int index)
{
    char *p = n+1;
    putchar(*p);
    for(p += 2; index; index--){
        putchar(*p ? *p++ : '0');
    }
    if(*p)
    {
        putchar('.');
        while(*p) putchar(*p++);
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章