1117 Eddington Number (25point(s)) - C語言 PAT 甲級

1117 Eddington Number (25point(s))

British astronomer Eddington liked to ride a bike. It is said that in order to show off his skill, he has even defined an “Eddington number”, E – that is, the maximum integer E such that it is for E days that one rides more than E miles. Eddington’s own E was 87.

Now given everyday’s distances that one rides for N days, you are supposed to find the corresponding E (≤N).

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​), the days of continuous riding. Then N non-negative integers are given in the next line, being the riding distances of everyday.

Output Specification:

For each case, print in a line the Eddington number for these N days.

Sample Input:

10
6 7 6 9 3 10 8 2 7 8

Sample Output:

6

題目大意:

1060 愛丁頓數 (25point(s))

設計思路:

1060 愛丁頓數(C語言)

  • 初看題目有點繞,讀懂題,重點在於求 E 天
  1. 降序排序騎車距離
  2. 天數由 0 升序,依次比較,即可找到最大天數
編譯器:C (gcc)
#include <stdio.h>

int comp(const void *a, const void *b)
{
    return *(int*)b - *(int*)a;
}

int main()
{
    int n, e, miles[100000];
    int i;

    scanf("%d", &n);
    for(i = 0; i < n; i++)
        scanf("%d", miles + i);
    qsort(miles, n, sizeof(int), comp);
    for(e = 0; e < n && miles[e] > e + 1; e++)
        continue;

    printf("%d\n", e);

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章