1116 Come on! Let‘s C (20point(s)) - C語言 PAT 甲級

1116 Come on! Let’s C (20point(s))

“Let’s C” is a popular and fun programming contest hosted by the College of Computer Science and Technology, Zhejiang University. Since the idea of the contest is for fun, the award rules are funny as the following:

  • 0、 The Champion will receive a “Mystery Award” (such as a BIG collection of students’ research papers…).
  • 1、 Those who ranked as a prime number will receive the best award – the Minions (小黃人)!
  • 2、 Everyone else will receive chocolates.

Given the final ranklist and a sequence of contestant ID’s, you are supposed to tell the corresponding awards.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤104), the total number of contestants. Then N lines of the ranklist follow, each in order gives a contestant’s ID (a 4-digit number). After the ranklist, there is a positive integer K followed by K query ID’s.

Output Specification:

For each query, print in a line ID: award where the award is Mystery Award, or Minion, or Chocolate. If the ID is not in the ranklist, print Are you kidding? instead. If the ID has been checked before, print ID: Checked.

Sample Input:

6
1111
6666
8888
1234
5555
0001
6
8888
0001
1111
2222
8888
2222

Sample Output:

8888: Minion
0001: Chocolate
1111: Mystery Award
2222: Are you kidding?
8888: Checked
2222: Are you kidding?

題目大意:

1059 C語言競賽 (20point(s))

設計思路:

1059 C語言競賽(C語言)

  • 用數組記錄相應的獲獎狀態
編譯器:C (gcc)
#include <stdio.h>

int isprime(int n)
{
    int i;
    for(i = 2; i * i <= n; i++)
        if(n % i == 0)
            return 0;
    return 1;
}

int main()
{
    int award[10000] = {0}, n, k, id;
    int i;

    scanf("%d", &n);
    for(i = 0; i < n; i++){
        scanf("%d", &id);
        if(i == 0)
            award[id] = 1;
        else if(isprime(i + 1))
            award[id] = 2;
        else
            award[id] = 3;
    }
    scanf("%d", &k);
    for(i = 0; i < k; i++){
        scanf("%d", &id);
        switch(award[id]){
            case 0: printf("%04d: Are you kidding?\n", id);             break;
            case 1: printf("%04d: Mystery Award\n", id); award[id] = 4; break;
            case 2: printf("%04d: Minion\n", id);        award[id] = 4; break;
            case 3: printf("%04d: Chocolate\n", id);     award[id] = 4; break;
            case 4: printf("%04d: Checked\n", id);                      break;
        }
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章