1120 Friend Numbers (20point(s)) - C語言 PAT 甲級

1120 Friend Numbers (20point(s))

Two integers are called “friend numbers” if they share the same sum of their digits, and the sum is their “friend ID”. For example, 123 and 51 are friend numbers since 1+2+3 = 5+1 = 6, and 6 is their friend ID. Given some numbers, you are supposed to count the number of different friend ID’s among them.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then N positive integers are given in the next line, separated by spaces. All the numbers are less than 104.

Output Specification:

For each case, print in the first line the number of different frind ID’s among the given integers. Then in the second line, output the friend ID’s in increasing order. The numbers must be separated by exactly one space and there must be no extra space at the end of the line.

Sample Input:

8
123 899 51 998 27 33 36 12

Sample Output:

4
3 6 9 26

題目大意:

1064 朋友數 (20point(s))

設計思路:

1064 朋友數(C語言)

  • 題目是朋友數,實際上求“朋友證號“,那就簡單了(是的,簡單了),最大數爲 9999,最大的證號爲 36,數組記錄一下然後輸出
編譯器:C (gcc)
#include <stdio.h>

int main()
{
        int n, num;
        int friends[37] = {0};
        int i, sum = 0, count = 0;

        scanf("%d", &n);
        for (i = 0; i < n; i++){
                scanf("%d", &num);
                for (sum = 0; num; num /= 10)
                        sum += num % 10;
                if (!friends[sum]){
                        friends[sum] = 1;
                        count++;
                }
        }

        printf("%d\n", count);
        for (i = 1; i < 37; i++)
                if (friends[i])
                        printf("%d%s", i, --count ? " " : "");

        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章