1104 Sum of Number Segments (20point(s)) - C语言 PAT 甲级

1104 Sum of Number Segments (20point(s))

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

题目大意:

1049 数列的片段和 (20point(s))

设计思路:

1049 数列的片段和(C语言)

  1. 方法一利用双重循环加和
  2. 方法二是直接根据数字的位置,计算这个数字被重复加了几次,
    设数字个数为 n,数字位于第 i 位,则:
    重复次数 = i * (n - i)
编译器:C (gcc)
#include <stdio.h>

int main()
{
    int n;
    double num, sum = 0.0;
    int i;

    scanf("%d", &n);
    for(i = 0; i < n; i++){
        scanf("%lf", &num);
        sum += num * (i + 1) * (n - i);
    }
    printf("%.2lf\n", sum);

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章