1101 Quick Sort (25point(s)) - C語言 PAT 甲級

1101 Quick Sort (25point(s))

1101 Quick Sort (25point(s))

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

  • 1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
  • 3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
  • 2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
  • and for the similar reason, 4 and 5 could also be the pivot.

Hence in total there are 3 pivot candidates.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤105). Then the next line contains N distinct positive integers no larger than 109. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

題目大意:

1045 快速排序 (25point(s))

設計思路:

1045 快速排序(C語言)
主要是降低時間複雜度

  1. 以主元的定義,暴力判斷,時間複雜度 O(N*N)
  2. 利用數組記錄每個數前面的最大值,後面的最小值,時間複雜度 O(N)

最初解題時很簡單的想到,在輸入時記錄每個數前面的最大值,然後就想怎麼記錄每個數後面的最小值,因爲數據是從前往後讀取,記錄最小值的方法越想越亂,最後看到大佬的代碼才反應過來,數據都存好了,從後往前再讀一次就是最小值(囧,想撞死在鍵盤上~~)

編譯器:C (gcc)
#include <stdio.h>

int main()
{
    int n, count = 0;
    int num[100000], lmax[100000], rmin[100000];
    int i, max, min;

    scanf("%d", &n);
    for(i = 0, max = i; i < n; i++){
        scanf("%d", num + i);
        lmax[i] = num[i] >= num[max] ? num[max = i] : num[max];
    }
    for(i = n - 1, min = i; i >= 0; i--){
        rmin[i] = num[i] <= num[min] ? num[min = i] : num[min];
    }
    for(i = 0; i < n; i++){
        if(num[i] == lmax[i] && num[i] == rmin[i]){
            count++;
        }
        else{
            num[i] = 0;
        }
    }
    printf("%d\n", count);
    for(i = 0; i < n && count; i++){
        if(num[i]){
            printf("%d%c", num[i], --count ? ' ' : '\0');
        }
    }
    printf("\n");

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章