1102 Invert a Binary Tree (25point(s)) - C語言 PAT 甲級

1102 Invert a Binary Tree (25point(s))

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

題目大意:

輸入 N 個樹的節點,依次給出節點的左右孩子節點序號

輸出該樹反轉後的層序序列,中序序列

設計思路:

樹的反轉是指,每個節點的左右子樹都做一次交換

  • 輸出遍歷序列時,其實就是先訪問右子樹,再訪問左子樹
  • 找到沒有父節點的根節點,按照先右子樹再左子樹遍歷輸出
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

int tree[20][2];

void levelorder(int root)
{
        int q[20] = {root}, front = 0, rear = 1, cnt = 1;
        while (cnt > 0) {
                root = q[front];
                front++;
                cnt--;
                printf("%s%d", front > 1 ? " " : "", root);
                if (tree[root][0] != -1) {
                        q[rear] = tree[root][0];
                        rear++;
                        cnt++;
                }
                if (tree[root][1] != -1) {
                        q[rear] = tree[root][1];
                        rear++;
                        cnt++;
                }
        }
}

int flag = 0;
void inorder(int root)
{
        if (root == -1)
                return ;
        inorder(tree[root][0]);
        printf("%s%d", flag > 0 ? " " : "", root);
        flag = 1;
        inorder(tree[root][1]);
}

int main(void)
{
        int n;
        int i, root = 0, child[20] = {0};
        char a[3], b[3];

        scanf("%d", &n);
        for (i = 0; i < n; i++) {
                scanf("%s %s", a, b);
                if (a[0] != '-') {
                        tree[i][1] = atoi(a);
                        child[atoi(a)] = 1;
                } else {
                        tree[i][1] = -1;
                }
                if (b[0] != '-') {
                        tree[i][0] = atoi(b);
                        child[atoi(b)] = 1;
                } else {
                        tree[i][0] = -1;
                }
        }

        while (child[root] == 1)
                root++;
        levelorder(root);
        puts("");
        inorder(root);
        return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章