Poj 1704 Georgia and Bob

Description

Georgia and Bob decide to play a self-invented game. They draw a row of grids on paper, number the grids from left to right by 1, 2, 3, ..., and place N chessmen on different grids, as shown in the following figure for example:


Georgia and Bob move the chessmen in turn. Every time a player will choose a chessman, and move it to the left without going over any other chessmen or across the left edge. The player can freely choose number of steps the chessman moves, with the constraint that the chessman must be moved at least ONE step and one grid can at most contains ONE single chessman. The player who cannot make a move loses the game.

Georgia always plays first since "Lady first". Suppose that Georgia and Bob both do their best in the game, i.e., if one of them knows a way to win the game, he or she will be able to carry it out.

Given the initial positions of the n chessmen, can you predict who will finally win the game?

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case contains two lines. The first line consists of one integer N (1 <= N <= 1000), indicating the number of chessmen. The second line contains N different integers P1, P2 ... Pn (1 <= Pi <= 10000), which are the initial positions of the n chessmen.

Output

For each test case, prints a single line, "Georgia will win", if Georgia will win the game; "Bob will win", if Bob will win the game; otherwise 'Not sure'.

Sample Input

2
3
1 2 3
8
1 5 6 7 9 12 14 17

Sample Output

Bob will win
Georgia will win

 

題意:給你n個棋子所在的位置,有兩個人輪流選擇其中一個棋子往右邊移動至少一個位置,不能越過其他棋子。當有人不能操作的時候,他就輸了。問你給你的狀態是必贏還是必輸?

 

解題思路:我們把棋子按位置升序排列後,從後往前把他們兩兩綁定成一對。如果總個數是奇數,就把最前面一個和邊界(位置爲0)綁定。 在同一對棋子中,如果對手移動前一個,你總能對後一個移動相同的步數,所以一對棋子的前一個和前一對棋子的後一個之間有多少個空位置對最終的結果是沒有影響的。於是我們只需要考慮同一對的兩個棋子之間有多少空位。我們把每一對兩顆棋子的距離(空位數)視作一堆石子,在對手移動每對兩顆棋子中靠右的那一顆時,移動幾位就相當於取幾個石子,與取石子游戲對應上了,各堆的石子取盡,就相當再也不能移動棋子了。

 

/*************************************************************************
	> File Name: poj1704.cpp
	> Author: baozi
	> Last modified: 2018年08月12日 星期日 22時31分
	> status:AC 
 ************************************************************************/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1e4+10;
int t,n,num[maxn];
int main(){
	int i,j;
	scanf("%d",&t);
	while(t--){
		scanf("%d",&n);
		for(i=1;i<=n;i++){
			scanf("%d",&num[i]);
		}
		sort(num+1,num+1+n);
		int ans=0;
		for(i=n;i>0;i-=2){
			int t=num[i]-num[i-1]-1;
			ans^=t;
		}
		if(ans) printf("Georgia will win\n");
		else printf("Bob will win\n"); 
	}
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章