POJ 2230 Watchcow

Watchcow
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 5362   Accepted: 2256   Special Judge

Description

Bessie's been appointed the new watch-cow for the farm. Every night, it's her job to walk across the farm and make sure that no evildoers are doing any evil. She begins at the barn, makes her patrol, and then returns to the barn when she's done.

If she were a more observant cow, she might be able to just walk each of M (1 <= M <= 50,000) bidirectional trails numbered 1..M between N (2 <= N <= 10,000) fields numbered 1..N on the farm once and be confident that she's seen everything she needs to see. But since she isn't, she wants to make sure she walks down each trail exactly twice. It's also important that her two trips along each trail be in opposite directions, so that she doesn't miss the same thing twice.

A pair of fields might be connected by more than one trail. Find a path that Bessie can follow which will meet her requirements. Such a path is guaranteed to exist.

Input

* Line 1: Two integers, N and M.

* Lines 2..M+1: Two integers denoting a pair of fields connected by a path.

Output

* Lines 1..2M+1: A list of fields she passes through, one per line, beginning and ending with the barn at field 1. If more than one solution is possible, output any solution.

Sample Input

4 5
1 2
1 4
2 3
2 4
3 4

Sample Output

1
2
3
4
2
1
4
3
2
4
1

Hint

OUTPUT DETAILS:

Bessie starts at 1 (barn), goes to 2, then 3, etc...

Source

 
題意:
給出不同點間可到達的邊,要求每條邊需正相反相各走一次
輸出通過的點的順序
 
代碼: 
#include<cstdio>
#include<cstring>
#define MAX 100005
#define N 10005

typedef struct 
{
	int to,next;
}Node;

Node edge[MAX];
int vist[MAX];
int head[N];
int n,m;
int cnt;

void Merge(int a,int b)
{
	edge[cnt].to=b;           //edge[i].to存儲第i條邊的終點	
	edge[cnt].next=head[a];   //edge[i].next存儲與第i條邊的終點共起點的邊的序號
	head[a]=cnt++;
}

void Dfs(int u)
{
	for(int i=head[u];i!=-1;i=edge[i].next)
	{
		int v=edge[i].to;
		if(!vist[i])
		{
			vist[i]=1;   //若vist[i]==1 說明第i條邊已經走過
			Dfs(v);
		}
	}
	printf("%d\n",u);
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(head,-1,sizeof(head));
		memset(vist,0,sizeof(vist));

		int a,b;
		cnt=0;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			Merge(a,b);   //放入不同的邊
			Merge(b,a);   //正反向均需走一次
		}

		Dfs(1);
	}
	return 0;
}

#include<cstdio>
#include<cstring>
#include<vector>
#define N 10005
using namespace std;

vector<int> edge[N];
vector<int> ans;
int pre[N];
int n,m;

void Dfs(int u)
{
	for(int &i=++pre[u];i<edge[u].size();i++)
	{
		int v=edge[u][i];
		Dfs(v);
		ans.push_back(v);
	}
}

int main()
{
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		memset(pre,-1,sizeof(pre));
		ans.clear();
		for(int i=0;i<=n;i++)
			edge[i].clear();

		int a,b;
		while(m--)
		{
			scanf("%d%d",&a,&b);
			edge[a].push_back(b);
			edge[b].push_back(a);
		}

		Dfs(1);
		printf("1\n");
		for(int i=ans.size()-1;i>=0;i--)
			printf("%d\n",ans[i]);
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章