[UVa 201]Squares 正方形,ACM/ICPC World Finals 1990

A children’s board game consists of a square array of dots that contains lines connecting some of the
pairs of adjacent dots. One part of the game requires that the players count the number of squares of
certain sizes that are formed by these lines. For example, in the figure shown below, there are 3 squares
— 2 of size 1 and 1 of size 2. (The “size” of a square is the number of lines segments required to form
a side.)
Your problem is to write a program that automates the process of counting all the possible squares.
Input
The input file represents a series of game boards. Each board consists of a description of a square array
of n
2 dots (where 2 ≤ n ≤ 9) and some interconnecting horizontal and vertical lines. A record for a
single board with n
2 dots and m interconnecting lines is formatted as follows:
Line 1: n the number of dots in a single row or column of the array
Line 2: m the number of interconnecting lines
Each of the next m lines are of one of two types:
H i j indicates a horizontal line in row i which connects
the dot in column j to the one to its right in column j + 1
or
V i j indicates a vertical line in column i which connects
the dot in row j to the one below in row j + 1
Information for each line begins in column 1. The end of input is indicated by end-of-file. The first
record of the sample input below represents the board of the square above.
Output
For each record, label the corresponding output with ‘Problem #1’, ‘Problem #2’, and so forth. Output
for a record consists of the number of squares of each size on the board, from the smallest to the largest.
lf no squares of any size exist, your program should print an appropriate message indicating so. Separate
output for successive input records by a line of asterisks between two blank lines, like in the sample
below.
Sample Input
4
16
H 1 1
H 1 3
H 2 1
H 2 2
H 2 3
H 3 2
H 4 2
H 4 3
V 1 1
V 2 1
V 2 2
V 2 3
V 3 2
V 4 1
V 4 2
V 4 3
2
3
H 1 1
H 2 1
V 2 1
Sample Output
Problem #1
2 square (s) of size 1
1 square (s) of size 2
************************’(兩個單引號是我加的,因爲我用的是MarkDown編輯器。。。)
Problem #2
No completed squares can be found.
題意:有n行n列(2<=n<=9)的點,還有m條線段連接其中的一些點。統計這些線段練成了多少個正方形。

解題思路:將讀進來的要添加的邊分別用兩個bool數組存,添加後就將相應的位置賦值成true,然後枚舉正方形的邊長和左上角頂點的位置,統計答案。

代碼

#include<bits/stdc++.h>
using namespace std;
int n,m,cnt;
int ans[20];
bool a[20][20],b[20][20];
int read(){
    int x=0,f=1;char ch=getchar();
    while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
    return x*f;
}
int main(){
    while(scanf("%d%d\n",&n,&m)!=EOF){
        cnt++;
        if(cnt!=1)puts("\n**********************************\n");
        memset(ans,0,sizeof(ans));
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        for(int i=1;i<=m;i++){
            char ch=getchar();int x=read(),y=read();
            if(ch=='H')a[x][y]=true;
            else b[y][x]=true;//這個lrj的紫書上的描述應該是b[x][y],但是原題上的描述是b[y][x] 
        }
        for(int s=1;s<n;s++){//枚舉正方形的邊長 
            int Ans=0;bool flag;
            for(int i=1;i<=n-s;i++)
                for(int j=1;j<=n-s;j++){//枚舉正方形左上角頂點的位置 
                    flag=true;
                    for(int x=i,y=j;flag&&x<i+s;x++)
                        if(!b[x][y]||!b[x][y+s])flag=false;//處理列 
                    for(int x=i,y=j;flag&&y<j+s;y++)
                        if(!a[x][y]||!a[x+s][y])flag=false;//處理行 
                    if(flag)Ans++;
                }
            ans[s]=Ans;
        }
        printf("Problem #%d\n\n",cnt);
        bool flag=false;
        for(int i=1;i<n;i++)
            if(ans[i]){printf("%d square (s) of size %d\n",ans[i],i);flag=true;}
        if(!flag)printf("No completed squares can be found.\n");//輸出 
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章