BZOJ 1635: [Usaco2007 Jan]Tallest Cow 最高的牛

1635: [Usaco2007 Jan]Tallest Cow 最高的牛

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 641  Solved: 390
[Submit][Status][Discuss]

Description

FJ's N (1 <= N <= 10,000) cows conveniently indexed 1..N are standing in a line. Each cow has a positive integer height (which is a bit of secret). You are told only the height H (1 <= H <= 1,000,000) of the tallest cow along with the index I of that cow. FJ has made a list of R (0 <= R <= 10,000) lines of the form "cow 17 sees cow 34". This means that cow 34 is at least as tall as cow 17, and that every cow between 17 and 34 has a height that is strictly smaller than that of cow 17. For each cow from 1..N, determine its maximum possible height, such that all of the information given is still correct. It is guaranteed that it is possible to satisfy all the constraints.

有n(1 <= n <= 10000)頭牛從1到n線性排列,每頭牛的高度爲h[i](1 <= i <= n),現在告訴你這裏面的牛的最大高度爲maxH,而且有r組關係,每組關係輸入兩個數字,假設爲a和b,表示第a頭牛能看到第b頭牛,能看到的條件是a, b之間的其它牛的高度都嚴格小於min(h[a], h[b]),而h[b] >= h[a]

Input

* Line 1: Four space-separated integers: N, I, H and R

 * Lines 2..R+1: Two distinct space-separated integers A and B (1 <= A, B <= N), indicating that cow A can see cow B.

Output

* Lines 1..N: Line i contains the maximum possible height of cow i.

Sample Input

9 3 5 5
1 3
5 3
4 3
3 7
9 8


INPUT DETAILS:

There are 9 cows, and the 3rd is the tallest with height 5.

Sample Output

5
4
5
3
4
4
5
5
5

HINT

Source


題解:說實話,很暴力,只是個思想,差分思想,但程序很暴力的。。。


代碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node{int x,y;}a[10001];
int f[10001];
int N,I,H,R;
int x,y,num;
bool cmp(node x,node y)
{
	if(x.x<y.x)return true;
	if(x.x==y.x&&x.y<y.y)return true;
	return false;
}
int main()
{
	scanf("%d%d%d%d",&N,&I,&H,&R);
	for(int i=1;i<=R;i++)
	{
		scanf("%d%d",&x,&y);
		if(y<x)swap(x,y);           //將x,y確定爲x<y,方便之後的計算 
		a[i].x=x;a[i].y=y;
	}
	sort(a+1,a+R+1,cmp);           //按x的從小到大來排,如果相等就按y
	                               //的從小到大來排,同樣方便之後的計算。。。cmp在上面 
	for(int i=1;i<=R;i++)
	{
		if(a[i].x==a[i-1].x&&a[i].y==a[i-1].y)continue;
		f[a[i].x+1]--;
		f[a[i].y]++;
	}                              //統計 
	for(int i=1;i<=N;i++)
	{
		num+=f[i];
		printf("%d\n",num+H);      //輸出 
	}
	return 0;
}



發佈了49 篇原創文章 · 獲贊 11 · 訪問量 7384
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章