BZOJ 1620: [Usaco2008 Nov]Time Management 時間管理

1620: [Usaco2008 Nov]Time Management 時間管理

Time Limit: 5 Sec  Memory Limit: 64 MB
Submit: 823  Solved: 520
[Submit][Status][Discuss]

Description

Ever the maturing businessman, Farmer John realizes that he must manage his time effectively. He has N jobs conveniently numbered 1..N (1 <= N <= 1,000) to accomplish (like milking the cows, cleaning the barn, mending the fences, and so on). To manage his time effectively, he has created a list of the jobs that must be finished. Job i requires a certain amount of time T_i (1 <= T_i <= 1,000) to complete and furthermore must be finished by time S_i (1 <= S_i <= 1,000,000). Farmer John starts his day at time t=0 and can only work on one job at a time until it is finished. Even a maturing businessman likes to sleep late; help Farmer John determine the latest he can start working and still finish all the jobs on time.

N個工作,每個工作其所需時間,及完成的Deadline,問要完成所有工作,最遲要什麼時候開始.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains two space-separated integers: T_i and S_i

Output

* Line 1: The latest time Farmer John can start working or -1 if Farmer John cannot finish all the jobs on time.

Sample Input

4
3 5
8 14
5 20
1 16

INPUT DETAILS:

Farmer John has 4 jobs to do, which take 3, 8, 5, and 1 units of
time, respectively, and must be completed by time 5, 14, 20, and
16, respectively.

Sample Output

2

OUTPUT DETAILS:

Farmer John must start the first job at time 2. Then he can do
the second, fourth, and third jobs in that order to finish on time.

HINT

Source


題解:按結束時間排序,從後往前掃一遍。。。然後輸出就好了。。。


代碼:

#include<bits/stdc++.h>
using namespace std;
int n,now=INT_MAX;
struct node{int x,y;}a[1001];
bool cmp(node a,node b){return a.y<b.y;}
int main()
{
	scanf("%d",&n);
	for(int i=1;i<=n;i++)
	   scanf("%d%d",&a[i].x,&a[i].y);
	sort(a+1,a+n+1,cmp);
	for(int i=n;i>=1;i--)
		now=min(now,a[i].y)-a[i].x;
	if(now<0)printf("-1");
	else printf("%d",now);
	return 0;
}



發佈了49 篇原創文章 · 獲贊 11 · 訪問量 7394
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章