FZU OJ 2111 Min Number (貪心)

Problem 2111 Min Number

Accept: 586    Submit: 1139
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Now you are given one non-negative integer n in 10-base notation, it will only contain digits ('0'-'9'). You are allowed to choose 2 integers i and j, such that: i!=j, 1≤i<j≤|n|, here |n| means the length of n’s 10-base notation. Then we can swap n[i] and n[j].

For example, n=9012, we choose i=1, j=3, then we swap n[1] and n[3], then we get 1092, which is smaller than the original n.

Now you are allowed to operate at most M times, so what is the smallest number you can get after the operation(s)?

Please note that in this problem, leading zero is not allowed!

 Input

The first line of the input contains an integer T (T≤100), indicating the number of test cases.

Then T cases, for any case, only 2 integers n and M (0≤n<10^1000, 0≤M≤100) in a single line.

 Output

For each test case, output the minimum number we can get after no more than M operations.

 Sample Input

39012 09012 19012 2

 Sample Output

901210921029

題意:給你一個數n,和交換次數m,要求經過m次交換之後的最小的數是多少,不能有前導零。

所以就把第一次的交換拿出來單獨考慮,首先貪心查找非零的最小值,然後把最小值和第一位交換,每交換一次,交換次數m--。
後面的也是一樣的,貪心查找之後位數的最小值,然後和前面的數進行比較,如果比前面的數小就交換。
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    char num[20000];
    int len, t, m, k, i, j;
    cin >> t;
    while (t--)
    {
        cin >> num >> m;
        len = strlen(num);
        if (m != 0)//m爲1的情況
        {
            for (i=0, k=0; i<len; i++)
            {
                if (num[i] < num[k] && num[i] != '0')//比較最小值
                {
                    k = i;
                }
            }
            if (num[0] > num[k])
            {
                swap(num[0], num[k]);//交換
                m--;
            }
        }
        for (i=1; i<len && m != 0; i++)//從第二位開始找
        {
            for (j=i, k=j; j<len; j++)//查找最小值
            {
                if (num[j] < num[k])
                {
                    k = j;
                }
            }
            if (num[i] > num[k])
            {
                swap(num[i], num[k]);//交換
                m--;
            }
        }
        cout << num << endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章