FZU OJ 2140 Forever 0.5 (幾何)

Problem 2140 Forever 0.5

Accept: 269    Submit: 934    Special Judge
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

 Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

 Sample Input

3235

 Sample Output

NoNoYes0.000000 0.525731-0.500000 0.162460-0.309017 -0.4253250.309017 -0.4253250.500000 0.162460

開始半天沒有讀懂題意,以爲這道題挺複雜的,後來讀懂了一點,原來也是比較水,有一點技巧。

題意:給你n個點,這n個點是否滿足下面的條件。

1.兩點之間的距離不大於1

2.任意點到原點的距離不大於1

3.有n對點的距離剛好等於1

4.n個點構成的n邊形的面積不小於0.5

5.n個點構成的n邊形的面積不大於0.75

如果滿足關係就輸出yes + 這n個點,沒有就輸出 no。

思路:畫個圖可以進行推敲一下,前四個點基本上都是確定的。3個點就是一個等邊三角形,(原點,x=1,y=0)但是面積不符合,所以滿足條件至少需要4個點,其實就是一個半徑爲1的圓以原點爲圓心。然後以原點和x軸畫一個邊長爲1的等邊三角形,這樣的話就有三個點了,然後剩下的點從圓上找就可以了,主要是離那三個點的距離大於1即可,因爲圓上的點到圓心的距離都爲1,其實就是將圓離散化。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
using namespace std;
double x[110],y[110];
const double temp=0.001;
void solve()
{
    x[0]=0,y[0]=0;//原點
    x[1]=1,y[1]=0;//第二個點
    x[2]=0.5,y[2]=sqrt(1-0.25);//等邊三角形的三個點 
    x[3]=0.5,y[3]=y[2]-1;
    for(int i=4;i<110;i++)
    {
        y[i]=i*temp;//離散化
        x[i]=sqrt(1-y[i]*y[i]);
    }
}
int main()
{
    int t,n;
    solve();
    cin>>t;
    while(t--)
    {
        cin>>n;
        if(n<4)
            printf("No\n");
        else
        {
            printf("Yes\n");
            for(int i=0;i<n;i++)
              printf("%.6lf %.6lf\n",y[i],x[i]);
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章