Kindergarten(二分圖)

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.
 

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers 
G, B (1 ≤ G, B ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and 
the number of pairs of girl and boy who know each other, respectively. 
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B. 

The last test case is followed by a line containing three zeros.
 

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.
 

Sample Input

2 3 3 1 1 1 2 2 3 2 3 5 1 1 1 2 2 1 2 2 2 3 0 0 0
 

Sample Output

Case 1: 3 Case 2: 4

解題思路

建圖時互相不認識的爲一個鏈接,就是求不認識的最小覆蓋數即完美匹配數,從n + m中減去它即可。



AC代碼

#include <cstdio>
#include <cstring>
#define N 205
int map[N][N], match[N], vis[N];
int n, m, k;

int find(int i)
{
    for(int j = 1; j <= m; j++)
    {
        if(!vis[j] && !map[i][j])
        {
            vis[j] = 1;
            if(match[j] == -1 || find(match[j]))
            {
                match[j] = i;
                return 1;
            }
        }
    }
    return 0;
}

int hungary()
{
    int ret = 0;
    memset(match, -1, sizeof(match));
    for(int i = 1; i <= n; i++)
    {
        memset(vis, 0, sizeof(vis));
        ret += find(i);
    }
    return ret;
}

int main()
{
    int x, y;
    int cas = 1;
    while(scanf("%d%d%d", &n, &m, &k), n + m + k)
    {
        memset(map, 0, sizeof(map));
        for(int i = 0; i < k; i++)
        {
            scanf("%d%d", &x, &y);
            map[x][y] = 1;
        }
        printf("Case %d: %d\n", cas++, n + m - hungary());
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章