poj 3261 Milk Patterns(可重疊的k 次最長重複子串)

Milk Patterns
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 10676   Accepted: 4792
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K 
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

題意:給定一個字符串,求至少出現k 次的最長重複子串,這k 個子串可以重疊,輸出該子串長度。
思路:先二分答案,然後將後綴分成若干組。這裏要判斷的是有沒有一個組的後綴個數不小於k。如果有,那麼存在
k 個相同的子串滿足條件,否則不存在。這個做法的時間複雜度爲O(nlogn)。

AC代碼:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#include <algorithm>
#include <queue>
#define ll long long
using namespace std;

const int maxn = 20005;
const int maxm = 20000;
const int INF = 1e9;

int s[maxn];
int sa[maxn], t[maxn], t2[maxn], c[maxn], n, K;
int rank[maxn], height[maxn];
void build_sa(int m){
    int i, *x = t, *y = t2;
    for(i = 0; i < m; i++) c[i] = 0;
    for(i = 0; i < n; i++) c[x[i] = s[i]]++;
    for(i = 1; i < m; i++) c[i] += c[i - 1];
    for(i = n - 1; i >= 0; i--) sa[--c[x[i]]] = i;
    for(int k = 1; k <= n; k <<= 1)
    {
        int p = 0;
        for(i = n - k; i < n; i++) y[p++] = i;
        for(i = 0; i < n; i++) if(sa[i] >= k) y[p++] = sa[i] - k;
        for(i = 0; i < m ; i++) c[i] = 0;
        for(i = 0; i < n; i++) c[x[y[i]]]++;
        for(i = 1; i < m; i++) c[i] += c[i - 1];
        for(i = n - 1; i >= 0; i--) sa[--c[x[y[i]]]] = y[i];
        swap(x, y);
        p = 1; x[sa[0]] = 0;
        for(i = 1; i < n; i++)
        x[sa[i]] = y[sa[i - 1]] == y[sa[i]] && y[sa[i - 1] + k] == y[sa[i] + k] ? p - 1 : p++;
        if(p >= n) break;
        m = p;
    }
}
void getHeight(){
    int i, j, k = 0;
    for(i = 0; i < n; i++) rank[sa[i]] = i;
    for(i = 0; i < n; i++)
    {
        if(k) k--;
        j = sa[rank[i] - 1];
        while(s[i + k] == s[j + k]) k++;
        height[rank[i]] = k;
    }
}
bool ok(int d){
    int i = 1;
    while(i < n)
    {
        while(i < n && height[i] < d) i++;
        int cnt = 1;
        while(i < n && height[i] >= d)
        {
            cnt++;
            i++;
        }
        if(cnt >= K) return true;
    }
    return false;
}
int solve(){
    int low = 0, high = n, ans = 0;
    while(low <= high)
    {
        int mid = (low + high) >> 1;
        if(ok(mid))
        {
            low = mid + 1;
            ans =  mid;
        }
        else high = mid - 1;

    }
    return ans;
}
int main()
{
    while(~scanf("%d%d", &n, &K))
    {
        for(int i = 0; i < n; i++)
        scanf("%d", &s[i]);
        build_sa(maxm);
        getHeight();
        printf("%d\n", solve());
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章