FatMouse and Cheese(記憶化搜索)

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10857    Accepted Submission(s): 4622


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.
 

Input
There are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected.
 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
37
 

Source
 

Recommend

記憶化搜索不過最多可以走k步

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <queue>
#define inf 110

using namespace std;

int a[inf][inf], dp[inf][inf];
int yi[4][2] = { {1, 0}, {-1, 0}, {0, 1}, {0, -1}};
int DFS(int x, int y);
int n, k;
int judge(int x, int y)
{
    if(x < 1 || x > n || y < 1 || y > n)
        return 1;
    return 0;
}
int main()
{
    while(~scanf("%d %d", &n, &k))
        {
            if(n < 1 || k < 1)
                break;
            memset(dp, 0, sizeof(dp));
            memset(a, 0, sizeof(a));
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= n; j++)
                    scanf("%d", &a[i][j]);
             int maxs = DFS(1, 1);
             printf("%d\n", maxs);
        }
    return 0;
}
int DFS(int x, int y)
{
    int xx, yy;
    if(!dp[x][y])
        {
            int ans = 0;
            for(int i = 1; i <= k; i++)
                for(int j = 0; j < 4; j++)
                    {
                        xx = x + yi[j][0] * i;
                        yy = y + yi[j][1] * i;
                        if(judge(xx, yy))
                            continue;
                        else if(a[xx][yy] > a[x][y])
                            ans = max(ans, DFS(xx, yy));
                    }
            dp[x][y] = ans + a[x][y];
        }
    return dp[x][y];
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章