ZJNU 1902 Why Did the Cow Cross the Road II dp

Why Did the Cow Cross the Road II

Time Limit: 3000MS Memory Limit: 3000K
Total Submissions: 30 Accepted: 10
Description

Farmer John raises N breeds of cows (1≤N≤1000), conveniently numbered 1…N. Some pairs of breeds are friendlier than others, a property that turns out to be easily characterized in terms of breed ID: breeds a and b are friendly if |a−b|≤4, and unfriendly otherwise.

A long road runs through FJ’s farm. There is a sequence of N fields on one side of the road (one designated for each breed), and a sequence of N fields on the other side of the road (also one for each breed). To help his cows cross the road safely, FJ wants to draw crosswalks over the road. Each crosswalk should connect a field on one side of the road to a field on the other side where the two fields have friendly breed IDs (it is fine for the cows to wander into fields for other breeds, as long as they are friendly). Each field can be accessible via at most one crosswalk (so crosswalks don’t meet at their endpoints).

Given the ordering of N fields on both sides of the road through FJ’s farm, please help FJ determine the maximum number of crosswalks he can draw over his road, such that no two intersect.

Input

The first line of input contains N. The next N lines describe the order, by breed ID, of fields on one side of the road; each breed ID is an integer in the range 1…N. The last N lines describe the order, by breed ID, of the fields on the other side of the road. Each breed ID appears exactly once in each ordering.

Output

Please output the maximum number of disjoint “friendly crosswalks” Farmer John can draw across the road.

Sample Input

6
1
2
3
4
5
6
6
5
4
3
2
1
Sample Output

5

題目鏈接

題意:給你左邊n個數,右邊n個數,按順序向下排,如果a[i]和b[j]的差值絕對值小於等於4,那麼我們就可以把他們連接起來,但是不能存在相交的情況,問最多可以連幾條線。

解題思路:dp即可,對於一個a[i]和b[j],如果他們的差值絕對值小於等於4,那麼,dp[i][j]=max(max(dp[i][j-1],dp[i-1][j]),dp[i-1][j-1]+1),否則,dp[i][j]=max(dp[i][j-1],dp[i-1][j]),因此我們直接dp暴力過,則dp[n][n]即爲答案。

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int dp[1005][1005],a[1005],b[1005];
int n,ans;
int main(){
    scanf("%d",&n);
    for(int i=1;i<=n;i++)   scanf("%d",&a[i]);
    for(int i=1;i<=n;i++)   scanf("%d",&b[i]);
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            if(abs(a[i]-b[j])<=4)   dp[i][j]=max(max(dp[i][j-1],dp[i-1][j]),dp[i-1][j-1]+1);
            else dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
        }
    }
    printf("%d\n",dp[n][n]);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章