hdu 4055 Number String(動態規劃)

Number String

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1728    Accepted Submission(s): 807


Problem Description
The signature of a permutation is a string that is computed as follows: for each pair of consecutive elements of the permutation, write down the letter 'I' (increasing) if the second element is greater than the first one, otherwise write down the letter 'D' (decreasing). For example, the signature of the permutation {3,1,2,7,4,6,5} is "DIIDID".

Your task is as follows: You are given a string describing the signature of many possible permutations, find out how many permutations satisfy this signature.

Note: For any positive integer n, a permutation of n elements is a sequence of length n that contains each of the integers 1 through n exactly once.
 

Input
Each test case consists of a string of 1 to 1000 characters long, containing only the letters 'I', 'D' or '?', representing a permutation signature.

Each test case occupies exactly one single line, without leading or trailing spaces.

Proceed to the end of file. The '?' in these strings can be either 'I' or 'D'.
 

Output
For each test case, print the number of permutations satisfying the signature on a single line. In case the result is too large, print the remainder modulo 1000000007.
 

Sample Input
II ID DI DD ?D ??
 

Sample Output
1 2 2 1 3 6
Hint
Permutation {1,2,3} has signature "II". Permutations {1,3,2} and {2,3,1} have signature "ID". Permutations {3,1,2} and {2,1,3} have signature "DI". Permutation {3,2,1} has signature "DD". "?D" can be either "ID" or "DD". "??" gives all possible permutations of length 3.

解題思路:

        f[i][j]代表前i個數,第i位爲j的時候的合法序列個數,sum[i][j]爲前i個數,第i位爲小於等於j的合法序列個數。當第i位爲I時f[i][j] = sum[i-1][j-1](代表前一位小於j),當第i位爲D時f[i][j] = sum[i-1][i-1] - sum[i-1][j-1](代表前一位大於j,因爲前面的j被i替換了,本來的等於也變成了大於,所以這個是sum[i-1][j-1]而不是sum[i-1][j]),當第i位爲?時f[i][j] = sum[i-1][i-1]。sum[i][j] = sum[i][j-1] + f[i][j]。

代碼:

#include <iostream>
#include <cstring>
#include <stdio.h>

using namespace std;

#define M 1000000007

long long f[1005][1005],sum[1005][1005];

int main()
{
    char s[1005];
    sum[1][0] = 0;
    sum[1][1] = 1;
    while(scanf("%s",s) != EOF){
        int n = strlen(s);
        for(int i = 2; i <= n+1; i ++){
            for(int j = 1; j <= i; j ++){
                f[i][j] = 0;
                if(s[i-2] == 'I' || s[i-2] == '?') f[i][j] += sum[i-1][j-1];
                if(j < i && (s[i-2] == 'D' || s[i-2] == '?')) f[i][j] += (sum[i-1][i-1] - sum[i-1][j-1] + M)%M;
                sum[i][j] = (sum[i][j-1] + f[i][j])%M;
            }
        }
        printf("%ld\n",sum[n+1][n+1]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章