hdu1062-Text Reverse

題目

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29143 Accepted Submission(s): 11468

Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

代碼

import java.util.*;
public class Main{
    public static void main(String[] args){
      Scanner sc=new Scanner(System.in);
      while(sc.hasNext()){
//        int n=sc.nextInt();//WA
         int n=Integer.parseInt(sc.nextLine());
         for(int i=0;i<n;i++){
            String s=sc.nextLine();
            String []str=s.split(" ");
            for(int j=0;j<str.length;j++){
                System.out.print(reverseString(str[j]));
                if(j<str.length-1)
                    System.out.print(" ");
              }
              if(s.endsWith(" "))//最後一個字符如果有空格
                  System.out.print(" ");
              System.out.println();
          }
      }
    }
    static String reverseString(String s){
        StringBuffer buf=new StringBuffer();
        buf.append(s);
        return buf.reverse().toString();
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章