hdu2029java-Palindromes _easy version

题目

Problem Description
“回文串”是一个正读和反读都一样的字符串,比如“level”或者“noon”等等就是回文串。请写一个程序判断读入的字符串是否是“回文”。

Input
输入包含多个测试实例,输入数据的第一行是一个正整数n,表示测试实例的个数,后面紧跟着是n个字符串。

Output
如果一个字符串是回文串,则输出”yes”,否则输出”no”.

Sample Input

4
level
abcde
noon
haha

Sample Output

yes
no
yes
no

###思路
比较原字符串与倒置取反的字符串是否相等

代码

import java.util.*;
public class Main{
    public static void main(String[] args){
        Scanner sc=new Scanner(System.in);
            while(sc.hasNext()){
                int n=sc.nextInt();
                sc.nextLine();
                for(int i=0;i<n;i++){
                    String s=sc.next();
                    StringBuffer buf=new StringBuffer();
                    buf.append(s);
                    String str=buf.reverse().toString();
                    if(s.equals(str))
                        System.out.println("yes");
                    else
                        System.out.println("no");
                }
            }
        }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章