1001. A+B Format (20)——C語言

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output

-999,991

#include<stdio.h>  
int main()  
{  
  int num1,num2;  
  int sum;  
  scanf("%d%d",&num1,&num2);
    sum = num1+num2;  
    if(sum < 0)
    {  
    printf("-");  
    sum = -sum;  
    }  
    if(sum>=1000000)
    {  
        printf("%d,%03d,%03d\n",sum/1000000, (sum/1000)%1000, sum%1000);  
    }  
    else if(sum >= 1000)
    {  
        printf("%d,%03d\n",sum/1000,sum%1000);  
    }
    else
    {  
        printf("%d\n", sum);  
    }  
  return 0;  
}  


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章