1001. A+B Format

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9

Sample Output

-999,991


題目大意:

給出a和b,計算a+b並按照格式從後往前數每三位一個逗號的格式輸出。


思路:

把數字轉換成字符串處理。


AC代碼:

#include <iostream>
#include <iomanip>
#include <stdio.h>
#include <stdlib.h>
#include <cmath>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <queue>
#include <stack>
using namespace std;

int main()
{
    int a,b,c,i,len;
    string num;
    stringstream ss;
    cin>>a>>b;
    c = a+b;
    if(c < 0)
    {
        cout<<"-";
        c = abs(c);
    }
    ss<<c;
    ss>>num;
    len = num.size();
    for(i=0;i<len;i++)
    {
        if((len-i)%3==0 && i!=0)
            cout<<",";
        cout<<num[i];
    }
    cout<<endl;
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章