【PAT 甲級】1001 A+B Format

1001 A+B Format (20)(20 分)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

題目大意:求兩個數的和,並用三位分節法表示結果。

注意這裏用到了一個新的取整數位數的方法,參考:點擊打開鏈接

	if(abs(sum)>1)
	{//取整數位數
	        len=1+(int)log10(abs(sum));
	}

我的完整代碼如下:

#include <iostream>
#include <cmath>
#include <string>
using namespace std;
int main()
{
	int a,b,sum,i=1,temp,len=1;
	cin>>a>>b;

	sum=a+b;
	if(abs(sum)>1)
	{//取整數位數
	        len=1+(int)log10(abs(sum));
	}
	int *s= new int [len+2]; //動態分配數組
	
	if(sum==0)
	{//如果合爲0,直接輸出0
		cout<<'0';
		system("pause");
		return 0;
	}
	temp=sum;

	while(sum!=0)
	{//從個位開始逐位存入
		s[i]=sum%10;
		sum=sum/10;
		i++;
	}

	//輸出
	if(temp<0)
	{
		cout<<'-';
	}
	for(int j=i-1;j>=1;j--)
	{
		if(j%3==0&&j!=i-1)
		{
			cout<<',';
		}
		cout<<abs(s[j]);
	}

        delete[] s;
	system("pause");
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章