【PAT 甲級】1027 Colors in Mars (20 分)

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

我的思路

這題表面上是顏色RGB轉換,實際就是10進制數轉13進制數。其中,大於9的數字用ABC替代,我採用ASCII碼的方式,A爲65。

	n = 11;
	printf("%c", n%10+65);
	//輸出B 

 

我的代碼

#include <cstdio>

//進制轉換函數 
int ext(int n)
{
	int i=0;
	int a[100]={0};
	if (n==0)
	{  //如果是0,直接輸出00 
		printf("00");
		return 1;
	}
	while(n!=0)
	{  //轉換成十三進制 
		a[i] = n%13;
		n = n/13;
		i++;
	}
	
	//輸出 	
	if (i==1) printf("0");  //如果轉換後不足兩位數,則左邊輸出0
	for (int j=i-1; j>=0; j--)
	{
		if(a[j]<10)
		{
			printf("%d", a[j]);
		} else
		{
			printf("%c", a[j]%10+65);  //把10/11/12變成A/B/C 
		}	
	}
	return 1;
}
 
int main()
{
	int r,g,b;
	scanf("%d %d %d", &r, &g, &b);
	printf("#");
	ext(r);ext(g);ext(b);
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章