【PAT 甲級】1035 Password (20 分)

1035 Password (20 分)

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @0 (zero) by %l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

我的思路

c++的字符串基本處理操作。最後輸出,直接把“\n”換行符存進字符串。

注意,不需要修改的時候,輸出的英語語句不同(1/多個,is/are ,名詞單/複數)。

 

我的代碼

#include <cstdio>
#include <string>
#include <iostream>
using namespace std;

int main()
{
	int N, c=0;
	string name, pw, put;
	bool flag = false;
	
	scanf("%d", &N);
	for(int i=1; i<=N; i++)
	{
		flag = false;
		cin >> name >> pw;
		for (int j=0; j<pw.length(); j++)
		{
			switch(pw[j])
			{
				case '1': pw[j] = '@'; flag = true; break;
				case '0': pw[j] = '%'; flag = true; break;
				case 'l': pw[j] = 'L'; flag = true; break;
				case 'O': pw[j] = 'o'; flag = true; break;
				default:;
			}
		}
		if (flag){
			c++;
			put += "\n" + name +" "+ pw;  //直接把換行和多個用戶信息存進一個字符串 
		}
	} 
	
	//輸出
	if (c)
	{
		cout << c << put;
	} else {  //單複數處理 
		if (N==1) cout << "There is " << N << " account and no account is modified";
			else cout << "There are " << N << " accounts and no account is modified";
	} 
	
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章