HDU 1061 Rightmost Digit

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
#include<stdio.h>
#include<math.h>
int main()
{
	int n,a,b,a1,b1,sum;
	scanf("%d",&n);
	for(int i=0;i<n;i++)
	{
		scanf("%d",&a);
		a1=a%10;
		b1=a%4;
		if(b1==0){
			sum=((int)pow(a1,4))%10;
	     	printf("%d\n",sum);
		}
		else{
			sum=((int)pow(a1,b1))%10;
	     	printf("%d\n",sum);
		} 
	}
 }


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章