HDU 1097 a hard puzzle


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
7 66 8 800
 

Sample Output
9

6

簡單來說,就是求前一個數的最後一個數的b次方的問題,很容易就看出來有規律,四個一循環,所以很容易就解決了。

#include<stdio.h>
#include<math.h>
int main()
{
	int a,b,a1,b1,sum;
	while(scanf("%d%d",&a,&b)!=EOF)
	{
		a1=a%10;
		b1=b%4;
		if(b1==0){
			sum=((int)pow(a1,4))%10;
	     	printf("%d\n",sum);
		}
		else{
			sum=((int)pow(a1,b1))%10;
	     	printf("%d\n",sum);
		} 
	}
 } 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章