Let the Balloon Rise

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
5 green red blue red red 3 pink orange pink 0
 

Sample Output
red
pink


簡單來說,這是一個求哪個顏色出現的次數最多的問題。
從問題的描述來看。很適合用map容器來解決問題,正好再熟悉一下map容器的用法。
同時參考了一些有關於c++迭代器的用法
#include<cstdio>
#include<map>
#include<string>
#include<iostream>
#include<vector>
using namespace std;
map<string,int> a;
map<string, int>::iterator iter;  //設置一個名爲iter的迭代器 
int main(){
	string b;	
	int n;
	while(cin>>n){
		if(n==0)
		break;
		string color="";
		a.clear();
		for(int i=0;i<n;i++){
			cin>>b;
			a[b]++;
		}
		int max=0;
		for(iter=a.begin();iter!=a.end();iter++){ //迭代器循環a的內容 
			if(iter->second>max){
				max=iter->second; //second代表鍵值 
				color=iter->first;//first代表鍵名 
			}
		}	
		cout<<color<<endl;	
	}	
} 
附上c++迭代器的參考博客

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章