HDU 1021 Fibonacci Again

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
0 1 2 3 4 5
 

Sample Output
no no yes no no
no
簡單的斐波那契數列,注意的是求和的時候也要mod3
#include<cstdio>
int a[1000001],n;
int main()
{
	a[0]=7;
	a[1]=11;
	for(int i=2;i<=1000000;i++)
	a[i]=(a[i-1]%3)+(a[i-2]%3);
	while(scanf("%d",&n)!=EOF){
		if(a[n]%3==0)
		printf("yes\n");
		else
		printf("no\n");
	}
 } 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章