Advanced Fruits(HDU1503)LCS

Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
apple peach ananas banana pear peach
 

Sample Output
appleach bananas pearch
 

Source
University of Ulm Local Contest 1999
/*聽大神說:簡單模板題。真是啪啪啪的打臉啦(羞羞)
開個數組標記一下相同的字符的狀態。然後輸出*/ 
#include<cstdio>
#include<cstring>
//#define max(a,b) (a>b?a:b)
const int n=1010;
char a[n],b[n];
int dp[n][n]; 
int mark[n][n];//標記數組 
int la,lb;
void lcs()
{
	int i,j;
	memset(dp,0,sizeof(dp));
	for(i=0;i<=la;++i)
	    mark[i][0]=1;
	for(i=0;i<=lb;++i)
	    mark[0][i]=2;
	for(i=1;i<=la;++i)
	{
		for(j=1;j<=lb;++j)
		{
			if(a[i-1]==b[j-1])
			{
				dp[i][j]=dp[i-1][j-1]+1;
				mark[i][j]=0;
			}
			else if(dp[i-1][j]>=dp[i][j-1])
			{
				dp[i][j]=dp[i-1][j];
				mark[i][j]=1;
			}
			else
			{
				dp[i][j]=dp[i][j-1];
				mark[i][j]=2;
			}
		}
	}
}
void PrintLCS(int i,int j)//根據回溯的位置進行輸出
{  
    if(!i && !j)  
    return ;  
    if(mark[i][j]==0)  
    {  
        PrintLCS(i-1,j-1);  
        printf("%c",a[i-1]);  
    }  
    else if(mark[i][j]==1)  
    {  
        PrintLCS(i-1,j);  
        printf("%c",a[i-1]);  
    }  
    else  
    {  
        PrintLCS(i,j-1);  
        printf("%c",b[j-1]);  
    }  
}  
int main()
{
	while(~scanf("%s%s",a,b))
	{
		la=strlen(a);
		lb=strlen(b);
		lcs();
		PrintLCS(la,lb);
		printf("\n");
//		printf("%d\n",dp[la][lb]);
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章