HDU 1159 Common Subsequence————LCS(最長公共子序列)模板題

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Input

abcfbc abfcab
programming contest 
abcd mnp

Output

4
2
0

Sample Input

abcfbc abfcab
programming contest 
abcd mnp

Sample Output

4
2
0

思路:

最長公共子序列模板題

 

#include<cstdio>
#include<cstdlib>
#include<cmath>
#include<cstring>
#include<string>
#include<iostream>
#include<stack>
#include<queue>
#include<algorithm>
#include<map>
#include<list>
#include<vector>

#define INF 0x3f3f3f3f
#define MAXN 1003

using namespace std;

int dp[MAXN][MAXN];
int main()
{
    char a[MAXN], b[MAXN];
    while(scanf("%s%s", a, b) != EOF)
    {
        int i, j;
        int len_a = strlen(a);
        int len_b = strlen(b);
        memset(dp, 0, sizeof(dp));
        for(i = 1; i <= len_a; i++)
        {
            for(j = 1; j <= len_b; j++)
            {
                if(a[i-1] == b[j-1])
                {
                    dp[i][j] = dp[i-1][j-1]+1;
                }
                else
                {
                    dp[i][j] = max(dp[i-1][j], dp[i][j-1]);
                }
            }
        }
        printf("%d\n", dp[len_a][len_b]);
    }

    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章