POJ 3070 斐波那契數列(矩陣快速冪(版題))

鏈接:http://poj.org/problem?id=3070

  • Fibonacci
    Time Limit: 1000MS Memory Limit: 65536K
    Total Submissions: 16351 Accepted: 11470

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

.

#include <iostream>
#include <string.h>

using namespace std;
const int maxn =15;
const int mod =10000;
struct matrix
{
    long long int a[2][2];
};
matrix multply(matrix x,matrix y)
{
    int i,j,k;
    matrix result;
    memset(result.a,0,sizeof(result.a));//**
    for (k=0; k<2; k++)
        for (i=0; i<2; i++)
        {
            if(x.a[i][k])
                for (j=0; j<2; j++)
                {
                    if (y.a[k][j])
                    {
                        result.a[i][j]+=x.a[i][k]*y.a[k][j];
                        if (result.a[i][j]>=mod)
                            result.a[i][j]%=mod;
                    }
                }

        }
    return result;
}
void  matrix_pow(matrix a,int nn)
{
    matrix result;
    memset(result.a,0,sizeof(result.a));
    int i,j,k;
    for (i=0; i<2; i++)
        result.a[i][i]=1;

    while (nn)
    {
        if (nn&1)
            result=multply(result,a);
        nn>>=1;
        a=multply(a,a);
//        int i,j;
//        for (i=0; i<2; i++)
//            for (j=0; j<2; j++)
//                if(!j)
//                    cout<<a.a[i][j]<<" ";
//                else
//                    cout <<a.a[i][j]<<endl;

    }
    cout<<result.a[0][1]<<endl;

}

int main ()
{
    long long int nn;
    while (cin>>nn)
    {
        if (nn==-1)
            break;
        matrix a;
        a.a[0][0]=a.a[0][1]=a.a[1][0]=1;
        a.a[1][1]=0;
//        int i,j;
//        for (i=0; i<2; i++)
//            for (j=0; j<2; j++)
//                if(!j)
//                    cout<<a.a[i][j]<<" ";
//                else
//                    cout <<a.a[i][j]<<endl;
        matrix_pow(a,nn);
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章