hdu1711 Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10731    Accepted Submission(s): 4879


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1
 
這是我KMP代碼的第一篇,心情好激動。。。
直接貼代碼吧:
#include<stdio.h>
#include<string.h>
int a[1000005];
int b[10005];
int next[10005];
int m,n;
void get_next()
{
    int i,j;
    next[1]=0;
    j=0;i=1;
    while(i<=m)
    {
        if(j==0||b[i]==b[j]) {i++;j++;next[i]=j;}
        else
            j=next[j];
    }     
}
int KMP() //注意此函數和get_next可不一樣
{
    int i,j;
    next[1]=0;
    i=1;j=1; //這裏ij分別是二者的起始位置
    while(i<=n&&j<=m)
    {
        if(j==0||a[i]==b[j]) {i++;j++;}//如果相等則比較下一個  不等就回溯 這裏不要再給next數組賦值了上面已經賦好了
        else
            j=next[j];

    }
    if(j>m) return i-m;
    else return -1;
}
int main()
{
      int i,t,ans;
      scanf("%d",&t);
      while(t--)
      {
          scanf("%d %d",&n,&m);
          for(i=1;i<=n;i++)
              scanf("%d",&a[i]);//注意從1開始輸入
          for(i=1;i<=m;i++)
              scanf("%d",&b[i]);
          get_next();
          ans=KMP();
          printf("%d\n",ans);
      }
      return 0;
}

對next 數組現在已有一個基本的瞭解:例如當文本串s[3]!=p[3]時,i=3不動,j=next[j]=next[3],j就有一個新的值
進行比較了。。。。。我理解的next 數組就這麼簡單生氣

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章