POJ - 3522 

Slim Span

description:

Given an undirected weighted graph G, you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V, E), where V is a set of vertices {v1, v2, …, vn} and E is a set of undirected edges {e1, e2, …, em}. Each edge e ∈ E has its weight w(e).
A spanning tree T is a tree (a connected subgraph without cycles) which connects all the n vertices with n − 1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T.
這裏寫圖片描述
Figure 5: A graph G and the weights of the edges

For example, a graph G in Figure 5(a) has four vertices {v1, v2, v3, v4} and five undirected edges {e1, e2, e3, e4, e5}. The weights of the edges are w(e1) = 3, w(e2) = 5, w(e3) = 6, w(e4) = 6, w(e5) = 7 as shown in Figure 5(b).
這裏寫圖片描述
Figure 6: Examples of the spanning trees of G

There are several spanning trees for G. Four of them are depicted in Figure 6(a)~(d). The spanning tree Ta in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the smallest weight is 3 so that the slimness of the tree Ta is 4. The slimnesses of spanning trees Tb, Tc and Td shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness of any other spanning tree is greater than or equal to 1, thus the spanning tree Td in Figure 6(d) is one of the slimmest spanning trees whose slimness is 1.

Your job is to write a program that computes the smallest slimness.

Input

The input consists of multiple datasets, followed by a line containing two zeros separated by a space. Each dataset has the following format.

n m
a1 b1 w1

am bm wm

Every input item in a dataset is a non-negative integer. Items in a line are separated by a space. n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and 0 ≤ m ≤ n(n − 1)/2. ak and bk (k = 1, …, m) are positive integers less than or equal to n, which represent the two vertices vak and vbk connected by the kth edge ek. wk is a positive integer less than or equal to 10000, which indicates the weight of ek. You can assume that the graph G = (V, E) is simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two or more edges whose both ends are the same two vertices).

Output

For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed. Otherwise, −1 should be printed. An output should not contain extra characters.

Sample Input

4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0

Sample Output

1
20
0
-1
-1
1
0
1686
50


題目大意:
對於一個無向圖來說,它可能有多個生成樹, 定義一個生成樹的slimness爲這個樹的邊的最大權值減去最小權值。試圖求出一個給定圖中所有生成樹中最小的slimness值。

解題思路:
1.對於kruskal算法來說,其各個邊是按照大小順序依次加入的,所以slimness值就是最後加入的邊長減去第一個加入的變邊長。
2.對於同一圖來說,最小生成樹可能有多個,但是其各個邊的權值一定是相等的。也就是不存在這樣的a+b = c+d,其中a,b爲最小生成樹x的邊 的權值而c,d爲最小生成樹y的邊的權值,而x,y均爲同一圖的最小生成樹。
3.繼而推廣,對於一個圖的最小生成樹的最小邊權值,其唯一對應一個最大邊的權值。
4.回到這道題,我們先將所有的邊全部記錄,然後枚舉最小邊的邊長,對於每一個最小邊長做一次Kruskal計算出silmness值。計算完當前邊以後,下一次計算將跳到下一個有更大的邊值的邊。
5.枚舉結束的條件可以設置多個:1.silmness值已經到0   2.從起始位置的邊到最大的邊,剩餘數量已經不足n-1(構不成生成樹了)  3.上次Kruskal計算中,已經求不出一個最小生成樹(後續的圖相當於前面求的圖的子圖,所以也將求不出最小生成樹)。


源代碼:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>

using namespace std;

int n,e;
int fa[105];
struct edg{
    int start,end;
    int cost;
    bool operator < (const edg& a) const{
        return cost<a.cost;
    }
}; 
edg roads[10000];

int find(int x){
    int r=x;
    while(r!=fa[r])
        r=fa[r];
    int i=x,j;
    while(fa[i]!=r){
        j=fa[i];
        fa[i]=r;
        i=j;
    }
    return r;
}  

int kruskal(int start_pos){
    for(int i=0;i<=n;i++)
      fa[i] = i;
    int now_choose=0;
    for(int i=start_pos;i<e;i++){
        int fs = find(roads[i].start);
        int fe = find(roads[i].end);        
        if(fs!=fe){
            fa[fs] = fe;
            now_choose++;
        }       
        if(now_choose==n-1){
            return roads[i].cost - roads[start_pos].cost;
        }
    }
    return -1;
}


int main(){
    while(scanf("%d%d",&n,&e)){
        if(n==0 && e==0)
          break;
        for(int i=0;i<e;i++){
            scanf("%d%d%d",&roads[i].start,&roads[i].end,&roads[i].cost);
        }
        sort(roads,roads+e);
        int start_pos = 0,last_len = -1,ans=1e9;
        while(ans  &&  e-start_pos>=n-1){
            int now_res = kruskal(start_pos);
            if(now_res>=0)
              ans = min(ans,now_res);
            else
              break; 
            last_len = roads[start_pos].cost;
            while(roads[start_pos].cost == last_len)
              start_pos++;
        }
        ans = ans==1e9?-1:ans;
        printf("%d\n",ans);
    }
    return 0;
} 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章