POJ 3191 - The Moronic Cowmpouter(進制轉換)

The Moronic Cowmpouter
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4192 Accepted: 2168
Description

Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it’s a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit.

You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, … (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on.

Eerily, negative numbers are also represented with 1’s and 0’s but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on.

Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.
Input

Line 1: A single integer to be converted to base −2
Output

Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.
Sample Input

-13
Sample Output

110111
Hint

Explanation of the sample:

Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13

題意:
給出一個數, 要求轉換成(-2)進制的形式.

解題思路:
正常的轉換, 但是有一個地方要注意.
如果除數(進制數)是一個負數, 被除數是負數且不能整除, 那麼商要+1.

AC代碼:

#include <iostream>
#include <vector>
using namespace std;
vector<int>a;
int main()
{
    long long n;
    cin >> n;
    if(n == 0)
        cout << 0; 
    while(n){
        if(n%(-2)){
            a.push_back(1);
        }
        else{
            a.push_back(0);
        }
        if(n < 0 && (n % -2))
        {
            n = n/-2+1;;
            continue;
        }
        n /= -2;
    }
    for(int i = a.size()-1; i >= 0; i--)
        cout << a[i];
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章